[haiku-bugs] Re: [Haiku] #6352: webpositive does not render arabic fonts.

  • From: "leavengood" <trac@xxxxxxxxxxxx>
  • Date: Tue, 12 Jul 2011 21:19:45 -0000

#6352: webpositive does not render arabic fonts.
----------------------------------------+------------------------
   Reporter:  khallebal                 |      Owner:  leavengood
       Type:  bug                       |     Status:  assigned
   Priority:  normal                    |  Milestone:  R1
  Component:  Applications/WebPositive  |    Version:  R1/alpha2
 Resolution:                            |   Keywords:
 Blocked By:                            |   Blocking:
Has a Patch:  0                         |   Platform:  All
----------------------------------------+------------------------
Changes (by leavengood):

 * owner:  stippi => leavengood
 * status:  new => assigned


Comment:

 Yeah this is related to #7053 and is indeed a WebKit problem (in our port)
 since Arabic is definitely complex text. The fact that BeZilla mostly
 works (the layout isn't perfect though) provides some hope that Haiku can
 at least display this text.

 I think soon I'll implement a basic version of complex text layout in our
 WebKit port and then someday explore properly implementing it using one of
 the complex text layout libraries, as [//www.freelists.org/post
 /haiku-development/Complex-Text-Layout-and-Rendering discussed on the
 mailing list ].

 That fact that you can test Arabic support is good, since you'll know
 better than me whether it is being displayed properly. Though I suppose
 displaying ''something'', even if imperfect, is better than nothing.

 I'll update this ticket when I've implementing basic support, hopefully in
 the next week or two.

-- 
Ticket URL: <http://dev.haiku-os.org/ticket/6352#comment:7>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: