[haiku-bugs] [Haiku] #16142: Locale: Inaccurate Defaults button behaviour

  • From: "Haiku" <trac@xxxxxxxxxxxx>
  • To: undisclosed-recipients: ;
  • Date: Tue, 26 May 2020 14:34:13 -0000

#16142: Locale: Inaccurate Defaults button behaviour
--------------------------------+-----------------------------
 Reporter:  bitigchi            |       Owner:  pulkomandy
     Type:  bug                 |      Status:  new
 Priority:  normal              |   Milestone:  Unscheduled
Component:  Preferences/Locale  |     Version:  R1/Development
 Keywords:                      |  Blocked By:
 Blocking:                      |    Platform:  All
--------------------------------+-----------------------------
 Currently Defaults button in Locale preflet changes everything back to
 English and English locale settings. This can be defined as inaccurate,
 because user sets this info for once in FirstBootPrompt, and these
 settings should be counted as the default. Changing everything back to
 pre-install settings is undesirable in this case.

 On the other hand, Revert button seems to function enough in this case.
 After setting the locale during install, if the user changes a setting by
 mistake, he/she can revert to the intended settings with this button.

 As I see, there are two possible solutions to this:

 - Have FirstBootPrompt create a separate defaults configuration, and have
 Defaults button refer to these settings
 - Remove Defaults button, and keep Revert. I am not sure if this covers
 all cases, but at the moment seems sufficient enough.
-- 
Ticket URL: <https://dev.haiku-os.org/ticket/16142>
Haiku <https://dev.haiku-os.org>
The Haiku operating system.

Other related posts: