[haiku-bugs] [Haiku] #14521: Failure in Setting up Atheros Wireless Network Adapter (WIFI on PC: FM V-Bibilo Loox U50X/V)

  • From: "Haiku" <trac@xxxxxxxxxxxx>
  • To: undisclosed-recipients: ;
  • Date: Mon, 24 Sep 2018 17:00:24 -0000

#14521: Failure in Setting up Atheros Wireless Network Adapter (WIFI on PC: FM
V-Bibilo Loox U50X/V)
-------------------------+------------------------------
 Reporter:  LeapingFrog  |        Owner:  nobody
     Type:  bug          |       Status:  new
 Priority:  normal       |    Milestone:  Unscheduled
Component:  - General    |      Version:  R1/Development
 Keywords:               |   Blocked By:
 Blocking:               |  Has a Patch:  0
 Platform:  All          |
-------------------------+------------------------------
 Haiku-OS
     haiku-master-hrev52357-x86_gcc2_hybrid-anyboot
 installed on PC (FM V-Bibilo Loox U50X/V) via USB
 fails to set-up WIFI.
 In the Terminal, I could not configure WIFI:
 ifconfig does not detect WIFI.
 However, listdev knows the device for WIFI.
 In the syslog, an error is reported in the process of setting up
 atheroswifi .

 {{{
 ~/documents/enter_Haiku> ls /dev/net
 rtl8139
 ~/documents/enter_Haiku> ifconfig -a
 loop    Hardware type: Local Loopback, Address: none
         inet addr: 127.0.0.1, Mask: 255.0.0.0
         inet6 addr: ::1, Prefix Length: 128
         MTU: 16384, Metric: 0, up loopback link
         Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
         Transmit: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
         Collisions: 0

 /dev/net/rtl8139/0
         Hardware type: Ethernet, Address: 00:17:42:8a:ec:78
         inet addr: --, Bcast: --, Mask: --
         MTU: 1500, Metric: 0, up broadcast
         Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
         Transmit: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
         Collisions: 0

 ~/documents/enter_Haiku> listdev
 ...
 device Network controller (Ethernet controller) [2|0|0]
   vendor 10ec: Realtek Semiconductor Co., Ltd.
   device 8139: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
 ...
 device Network controller (Ethernet controller) [2|0|0]
   vendor 168c: Qualcomm Atheros
   device 001c: AR242x / AR542x Wireless Network Adapter (PCI-Express)
 ...
 }}}
 ------- /Haiku/system/var/log/syslog -------
 {{{
 ...
 KERN: package_daemon [30308584:   337] Volume::InitialVerify(): volume at
 "/boot/home/config" is consistent
 KERN: [atheroswifi] (ath_pci) bus_alloc_resource(3, [16], 0x0, 0xffffffff,
 0x1,0x2)
 KERN: add_memory_type_range(4011, 0xf0000000, 0x10000, 0)
 KERN: set MTRRs to:
 KERN:   mtrr:  0: base: 0x3f670000, size:    0x10000, type: 0
 KERN:   mtrr:  1: base: 0x3f680000, size:    0x80000, type: 0
 KERN:   mtrr:  2: base: 0xf0000000, size: 0x10000000, type: 0
 KERN:   mtrr:  3: base: 0x80000000, size: 0x80000000, type: 1
 KERN: [atheroswifi] (ath_pci) bus_alloc_resource(1, [0], 0x0, 0xffffffff,
 0x1,0x6)
 KERN: [atheroswifi] (ath_pci) unable to attach hardware; HAL status 3
 KERN: remove_memory_type_range(4011, 0xf0000000, 0x10000, 0)
 KERN: set MTRRs to:
 KERN:   mtrr:  0: base: 0x3f670000, size:    0x10000, type: 0
 KERN:   mtrr:  1: base: 0x3f680000, size:    0x80000, type: 0
 KERN:   mtrr:  2: base: 0xf0000000, size: 0x10000000, type: 0
 KERN:   mtrr:  3: base: 0x80000000, size: 0x80000000, type: 1
 KERN: loaded driver /boot/system/add-ons/kernel/drivers/dev/input/usb_hid
 ...
 }}}

 I verified the WIFI by rebooting Windows Vista.
 Windows Vista detects WIFI and routers.
 After that I rebooted Haiku-OS again.
 Then, I collected the data and included in this bug-report.

-- 
Ticket URL: <https://dev.haiku-os.org/ticket/14521>
Haiku <https://dev.haiku-os.org>
The Haiku operating system.

Other related posts: