[haiku-bugs] [Haiku] #13620: Strange/wrong channel attachment by generic ATA with more than one IDE/ATA controller

  • From: "Alexco" <trac@xxxxxxxxxxxx>
  • Date: Sun, 23 Jul 2017 09:44:18 -0000

#13620: Strange/wrong channel attachment by generic ATA with more than one 
IDE/ATA
controller
------------------------------+------------------------------
 Reporter:  Alexco            |        Owner:  nobody
     Type:  bug               |       Status:  new
 Priority:  normal            |    Milestone:  Unscheduled
Component:  Drivers/Disk/ATA  |      Version:  R1/Development
 Keywords:                    |   Blocked By:
 Blocking:                    |  Has a Patch:  0
 Platform:  All               |
------------------------------+------------------------------
 My BeOS/Haiku test system features 2 dedicated IDE controllers, each with
 2 separate channels. One is the chipset one (Intel BX440), the other is a
 Highpoint 366. While investigating why the Highpoint is not supported, I
 found that the channel assignment in device tree is messed up (tested with
 hrev51219).
 If you look at the distdev output you can see that the Intel channel is
 attached to the Highpoint PCI (vendor 0x1103) device while the device
 attached to the Highpoint is not seen as all.

 Looking at the dmesg output of FreeBSD confirms that all addresses are
 identified correctly.

--
Ticket URL: <https://dev.haiku-os.org/ticket/13620>
Haiku <https://dev.haiku-os.org>
The Haiku operating system.

Other related posts: