[haiku-bugs] Re: [Haiku] #10835: Package system does not warn on downgrading packages

  • From: "bonefish" <trac@xxxxxxxxxxxx>
  • Date: Thu, 15 May 2014 17:11:28 -0000

#10835: Package system does not warn on downgrading packages
-----------------------------------------------+---------------------------
   Reporter:  waddlesplash                     |      Owner:  nobody
       Type:  enhancement                      |     Status:  new
   Priority:  normal                           |  Milestone:  R1
  Component:  Applications/Command Line Tools  |    Version:
 Resolution:                                   |  R1/Development
 Blocked By:                                   |   Keywords:
Has a Patch:  0                                |   Blocking:
                                               |   Platform:  All
-----------------------------------------------+---------------------------
Changes (by bonefish):

 * owner:  bonefish => nobody
 * type:  bug => enhancement
 * component:  Kits/Package Kit => Applications/Command Line Tools


Comment:

 `pkgman full-sync --help` already says that packages may be downgraded or
 removed. The command overview `pkgman --help` gives does not, but I
 wouldn't add more text there and I think the wording makes it clear that
 this operation is not an update (in `zypper` the command is named `dist-
 upgrade`, which I intentionally deviated from, since I don't find it very
 helpful in conveying that information).

 Anyway, changing the ticket type to enhancement for the more detailed
 categories.

--
Ticket URL: <https://dev.haiku-os.org/ticket/10835#comment:5>
Haiku <https://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: