[haiku-bugs] [Haiku] #10835: Package system does not warn on downgrading packages

  • From: "waddlesplash" <trac@xxxxxxxxxxxx>
  • Date: Wed, 14 May 2014 17:45:57 -0000

#10835: Package system does not warn on downgrading packages
------------------------------+------------------------------
 Reporter:  waddlesplash      |        Owner:  bonefish
     Type:  bug               |       Status:  new
 Priority:  normal            |    Milestone:  R1
Component:  Kits/Package Kit  |      Version:  R1/Development
 Keywords:                    |   Blocked By:
 Blocking:                    |  Has a Patch:  0
 Platform:  All               |
------------------------------+------------------------------
 While testing some stuff related to #10278, I found that if you have a
 newer version of a package installed than is available from the repo (e.g.
 I have hrev47221 installed but only hrev47215 is available) it will simply
 continue without confirming.


 I think the correct thing to do here would be to require a specific
 command line argument (e.g. --force) to downgrade any package version, and
 perhaps something more than that for the base system packages.

--
Ticket URL: <https://dev.haiku-os.org/ticket/10835>
Haiku <https://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: