[haiku-bugs] [Haiku] #10731: atomic.o causes jam quit, in Haiku x86_64 (hrev46641)

  • From: "Luposian" <trac@xxxxxxxxxxxx>
  • Date: Mon, 31 Mar 2014 23:23:16 -0000

#10731: atomic.o causes jam quit, in Haiku x86_64 (hrev46641)
--------------------------+------------------------------
 Reporter:  Luposian      |        Owner:  bonefish
     Type:  bug           |       Status:  new
 Priority:  normal        |    Milestone:  R1
Component:  Build System  |      Version:  R1/Development
 Keywords:                |   Blocked By:
 Blocking:                |  Has a Patch:  0
 Platform:  x86-64        |
--------------------------+------------------------------
 I am using Haiku x86_64 (hrev46641).  After downloading all buildtools and
 the Haiku source tree, building the tools, and doing a ./configure, I
 type:

 jam -q haiku-image.

 It goes along fine and then quits at Atomic.o, as shown.  I can get it to
 go further, if I don't include the -q, but then I get various error
 messages saying that a certain program (I think it's when it's trying to
 download a file during the Jam), quit unexpectedly and that I have to
 select what I want to do.  I click on "File report".

 Eventually, after clicking through a bunch of those error messages, it
 quits anyways, due to too many failed/skipped files, etc.

 My assumption is you should always use -q when running Jam, correct?

 I would use Haiku x86_64 (hrev47061; latest version available on
 HaikuFiles, as of this ticket), but Web+ crashes on it and running Jam
 eventually causes the screen to black out and render the system totally
 unresponsive, requiring a manual reboot.

 At least with hrev46641, I can use Web+ and the system seems fair
 stable/usable otherwise.

--
Ticket URL: <https://dev.haiku-os.org/ticket/10731>
Haiku <https://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: