[haiku-bugs] Re: [Haiku] #10134: DriveSetup: some new functions

  • From: "axeld" <trac@xxxxxxxxxxxx>
  • Date: Sat, 21 Dec 2013 21:31:41 -0000

#10134: DriveSetup: some new functions
   Reporter:  dsjonny                  |      Owner:  stippi
       Type:  enhancement              |     Status:  new
   Priority:  normal                   |  Milestone:  R1
  Component:  Applications/DriveSetup  |    Version:  R1/Development
 Resolution:                           |   Keywords:
 Blocked By:                           |   Blocking:
Has a Patch:  1                        |   Platform:  All

Comment (by axeld):

 I think the window is much to colorful with your changes, and the icons
 have the most part of the responsibility for that. Besides that, I don't
 think they are matching either: the expected icon for an encrypted disk
 would be a lock. I would expect the "cannot access" symbol when the system
 cannot access the disk (ie. because of a malfunction).

 What exactly do you not understand?

 * The new EncryptionType() method is still broken: you still append a
 potentially unterminated buffer to a string.
 * There are still lots of coding style violations in that code. Just two
 examples: always use boolean comparison in if (not "if (fIcon)" but "if
 (fIcon != NULL)"), the inline IsEncypted() method has wrong parenthesis.
 Wrong indentation of the return type of EncryptionType(), inconsistent
 asterisk style, etc, etc, etc.
 * If you return in an "if", there is no need for "else".
 * Please make all methods const that can be const (like IsEncrypted(), or
 * fIsBFS would be a better name.
 * What does "Virtual" mean to you?
 * Or "Mimes"?
 * Line 560 in MainWindow.cpp looks broken.
 * Still no error checking in things like WriteDiskImage() - try or not,
 this is not acceptable.
 * Now that I see what does, it looks as superfluous as SaveDiskImage(),
 though. The only thing that would make some sense would be an option to
 create a disk image of a certain size, the rest can be removed.

 In any case, thank you for your contribution - I just think that you at
 least need to try harder to follow our coding style to get the patch to a
 state where it could be applied before even looking at its functionality.

Ticket URL: <http://dev.haiku-os.org/ticket/10134#comment:17>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: