[haiku-bugs] Re: [Haiku] #10134: DriveSetup: some new functions

  • From: "stippi" <trac@xxxxxxxxxxxx>
  • Date: Mon, 16 Dec 2013 08:28:38 -0000

#10134: DriveSetup: some new functions
   Reporter:  dsjonny                  |      Owner:  stippi
       Type:  enhancement              |     Status:  new
   Priority:  normal                   |  Milestone:  R1
  Component:  Applications/DriveSetup  |    Version:  R1/Development
 Resolution:                           |   Keywords:
 Blocked By:                           |   Blocking:
Has a Patch:  1                        |   Platform:  All

Comment (by stippi):

 There are different coding style rules for function names when they are a
 class method or a (static) function by themselves. You should really read
 the coding style guide carefully when you want your patches in. Haiku
 developers really don't want to add code to existing applications that
 follows a different coding style or is simply not easy to read code. Clean
 code is easy to read and understand for people who have not written it.
 That means meaningful variable names and short methods that serve a single
 purpose. If you have long methods that do various things, it's called
 "spaghetti-code". Also, it is never useful to point out other places in
 Haiku code that could be improved or that doesn't follow the style guide.
 That is not a good excuse for degrading the code quality even more.
 Instead, it should gradrually improve over time, for example by accepting
 only nicely written patches.

Ticket URL: <http://dev.haiku-os.org/ticket/10134#comment:8>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: