[haiku-appserver] Re: r14920 - haiku/trunk/src/servers/app

  • From: Adi Oanca <adioanca@xxxxxxxxx>
  • To: haiku-appserver@xxxxxxxxxxxxx
  • Date: Wed, 16 Nov 2005 19:47:27 +0200

Axel Dörfler wrote:

Adi Oanca <adioanca@xxxxxxxxx> wrote:

Axel Dörfler wrote:

Therefore, I'll do the following next (when resuming to work on that place):
a) I will introduce GetExtent() as proposed
b) I will fix the design and remove *all* RootLayer references in the layer class
(and if that includes a RootLayer::GetIntersectWith() or whatever is necessary, so be it - if you're not happy with that name, just propose another one, of course)

Any objections?

Just one, related to RootLayer::GetIntersectWith(). Make it ConstrainToScreenRect(). Make that and we're both happy. :-)

Yes, that sounds good (although it should be *Region(), as it doesn't have to be a rect :-))

Correct! ;-)

I can't believe we're through this :-))

Yap! Boy, it was a long ride! :-) And what an interesting subject!!! :-))

bye, Adi.

Other related posts: