Adi Oanca <adioanca@xxxxxxxxx> wrote: > Axel Dörfler wrote: > > Therefore, I'll do the following next (when resuming to work on > > that > > place): > > a) I will introduce GetExtent() as proposed > > b) I will fix the design and remove *all* RootLayer references in > > the > > layer class > > (and if that includes a RootLayer::GetIntersectWith() or whatever > > is > > necessary, so be it - if you're not happy with that name, just > > propose > > another one, of course) > > > > Any objections? > Just one, related to RootLayer::GetIntersectWith(). Make it > ConstrainToScreenRect(). Make that and we're both happy. :-) Yes, that sounds good (although it should be *Region(), as it doesn't have to be a rect :-)) I can't believe we're through this :-)) Bye, Axel.