[gpumd] Re: Question about EMD and triclinic boxes

  • From: Joakim Brorsson <joabro@xxxxxxxxxxx>
  • To: "gpumd@xxxxxxxxxxxxx" <gpumd@xxxxxxxxxxxxx>
  • Date: Mon, 27 Jan 2020 18:55:08 +0000

Hi Zheyong

I have attached tar archives with the potentials as well as the input files. 
Interestingly, the first 158 lines in thermos.out, which I have attached, looks 
fine, but then something happens since the first 6 columns become nan.

With regards

Joakim

From: <gpumd-bounce@xxxxxxxxxxxxx> on behalf of Bruce Fan <brucenju@xxxxxxxxx>
Reply-To: "gpumd@xxxxxxxxxxxxx" <gpumd@xxxxxxxxxxxxx>
Date: Monday, 27 January 2020 at 16:03
To: "gpumd@xxxxxxxxxxxxx" <gpumd@xxxxxxxxxxxxx>
Subject: [gpumd] Re: Question about EMD and triclinic boxes

yes, I need one example to reproduce the error.

Zheyong

Joakim Brorsson <joabro@xxxxxxxxxxx<mailto:joabro@xxxxxxxxxxx>> 于 2020年1月27日周一 
13:34写道:
Hi Zheyong

I am experiencing a similar problem. When I run simulations for a triclinic 
case I get nan values in the output from comute_hnemd, compute_dos, compute_shc 
as well as dump_thermo so this problem seems to be quite general in nature. I 
am running a few simulations for a orthogonal cell, but these are not finished. 
Do you want me to send you the input files?

With regards

Joakim

From: <gpumd-bounce@xxxxxxxxxxxxx<mailto:gpumd-bounce@xxxxxxxxxxxxx>> on behalf 
of Bruce Fan <brucenju@xxxxxxxxx<mailto:brucenju@xxxxxxxxx>>
Reply-To: "gpumd@xxxxxxxxxxxxx<mailto:gpumd@xxxxxxxxxxxxx>" 
<gpumd@xxxxxxxxxxxxx<mailto:gpumd@xxxxxxxxxxxxx>>
Date: Friday, 24 January 2020 at 18:49
To: "gpumd@xxxxxxxxxxxxx<mailto:gpumd@xxxxxxxxxxxxx>" 
<gpumd@xxxxxxxxxxxxx<mailto:gpumd@xxxxxxxxxxxxx>>
Subject: [gpumd] Re: Question about EMD and triclinic boxes

Hi Fredrik, Could you send all the inputs for the triclinic case? And the 
latest developing version is used?

Zheyong
Fredrik Eriksson <freeriks@xxxxxxxxxxx<mailto:freeriks@xxxxxxxxxxx>> 于 
2020年1月24日周五 19:41写道:

Hi!



I'm trying to run the EMD method using the built in MoS2 potential.  For 
orthogonal boxes it works fine
xyz.in<http://xyz.in>:
1350 744 5 0 0 0
1 1 1 28.33917984  27.26938851539536 31.0

but if the box is triclinic

xyz.in<http://xyz.in>:
1350 744 5 1 0 0
1 1 1 28.33917984 0.0 0.0 0.0 27.26938851539536 0.0 0.0 0.0 31.0


it seem to output -nan and inf in column 7-11 in the hac.out file.



Is this a bug or a feature? Can I still trust the hac results and compute the 
thermal conductivity manually?



Cheers!

Fredrik Eriksson

Attachment: ols_original_model_5_2x2x2_all_orders_tol1e-08.tar.gz
Description: ols_original_model_5_2x2x2_all_orders_tol1e-08.tar.gz

Attachment: hnemd_test.tar.gz
Description: hnemd_test.tar.gz

Attachment: thermo.out
Description: thermo.out

Other related posts: