[gpumd] Re: Question about EMD and triclinic boxes

  • From: Bruce Fan <brucenju@xxxxxxxxx>
  • To: gpumd@xxxxxxxxxxxxx
  • Date: Mon, 27 Jan 2020 17:03:14 +0200

yes, I need one example to reproduce the error.

Zheyong

Joakim Brorsson <joabro@xxxxxxxxxxx> 于 2020年1月27日周一 13:34写道:

Hi Zheyong



I am experiencing a similar problem. When I run simulations for a
triclinic case I get nan values in the output from comute_hnemd,
compute_dos, compute_shc as well as dump_thermo so this problem seems to be
quite general in nature. I am running a few simulations for a orthogonal
cell, but these are not finished. Do you want me to send you the input
files?



With regards



Joakim



*From: *<gpumd-bounce@xxxxxxxxxxxxx> on behalf of Bruce Fan <
brucenju@xxxxxxxxx>
*Reply-To: *"gpumd@xxxxxxxxxxxxx" <gpumd@xxxxxxxxxxxxx>
*Date: *Friday, 24 January 2020 at 18:49
*To: *"gpumd@xxxxxxxxxxxxx" <gpumd@xxxxxxxxxxxxx>
*Subject: *[gpumd] Re: Question about EMD and triclinic boxes



Hi Fredrik, Could you send all the inputs for the triclinic case? And the
latest developing version is used?



Zheyong

Fredrik Eriksson <freeriks@xxxxxxxxxxx> 于 2020年1月24日周五 19:41写道:

Hi!



I'm trying to run the EMD method using the built in MoS2 potential.  For
orthogonal boxes it works fine

xyz.in:

1350 744 5 0 0 0
1 1 1 28.33917984  27.26938851539536 31.0

but if the box is triclinic

xyz.in:

1350 744 5 1 0 0
1 1 1 28.33917984 0.0 0.0 0.0 27.26938851539536 0.0 0.0 0.0 31.0



it seem to output -nan and inf in column 7-11 in the hac.out file.



Is this a bug or a feature? Can I still trust the hac results and compute
the thermal conductivity manually?



Cheers!

Fredrik Eriksson


Other related posts: