[gmpi] Entry Point Function

  • From: Jeff McClintock <jeffmcc@xxxxxxxxxx>
  • To: gmpi@xxxxxxxxxxxxx
  • Date: Tue, 15 Feb 2005 13:30:46 +1300

"DllGetClassObject" is the curent name of the GIMPI entry point. This is the standard name for a COM component entry point.

It's COM-speak for "get me the factory".

Part1: Do we insist on full COM compatibility?, or are we just picking the elements of COM most useful to us?

If we don't need COM compatibility, we can call it what we like.

Part2: What would you prefer to call it?

Jeffs opinion: We shouldn't stress too much about trivial details. This is barely worth discussing. We have very interesting things to move on to. However, whatever the group decides is fine with me.

---------------------------------------------------------------------- Generalized Music Plugin Interface (GMPI) public discussion list Participation in this list is contingent upon your abiding by the following rules: Please stay on topic. You are responsible for your own words. Please respect your fellow subscribers. Please do not redistribute anyone else's words without their permission.

Archive: //www.freelists.org/archives/gmpi
Email gmpi-request@xxxxxxxxxxxxx w/ subject "unsubscribe" to unsubscribe

Other related posts: