Compilation of emelFM2

  • From: Manfred Richter <manfred@xxxxxx>
  • To: emelfm2@xxxxxxxxxxxxx
  • Date: Tue, 25 Nov 2014 09:46:25 +0100

I tried to compile emelFM2.
After the first call to make I found i should install a library:

apt-get install libwebkit-dev

next call to make:

compiling 'src/e2_print.c'
In file included from src/utils/e2_hook.h:23:0,
                 from src/emelfm2.h:585,
                 from src/e2_print.c:20:
src/utils/e2_utils.h:86:2: error: expected specifier-qualifier-list before ‘magic_t’
  magic_t (*open) (gint);
  ^
Makefile:433: recipe for target 'objs/src/e2_print.o' failed
make: *** [objs/src/e2_print.o] Error 1


What should I do now?

Greetings, Manfred.



--
Users can unsubscribe from the list by sending email to 
emelfm2-request@xxxxxxxxxxxxx with 'unsubscribe' in the subject field or by 
logging into the web interface.

Other related posts: