[argyllcms] Re: libusb_handle_events_check

  • From: Graeme Gill <graeme@xxxxxxxxxxxxx>
  • To: argyllcms@xxxxxxxxxxxxx
  • Date: Wed, 19 May 2010 22:41:27 +1000

Richard Hughes wrote:
I'm trying to compile the argyll developer snapshot with libusb1
support (which is great for stability, thanks) but can't resolve the
following symbol: libusb_handle_events_check.
I can't find it in libusb1 upstream, just in the argyll in-tree copy.
In Fedora we can't bundle libusb1. Could you please push this upstream
to Daniel if this belongs in the libusb1 api. Thanks.

It's already been pushed upstream, but hasn't been included in
any release, nor is there any indication when/if it will be,
even though it fixes a critical race condition.

I've tested the included libusb1 on all instruments on all supported
platforms and fixed all the bugs this uncovered (there were many). Since
upstream hasn't adopted all the bugfixes I've provided, and will not be
doing comparable testing, you can't currently use upstream libusb1 with
Argyll.

Graeme Gill.

Other related posts: