[argyllcms] Warning issued from 1.9.0 beta with NVidia driver

  • From: Colin Adams <colinpauladams@xxxxxxxxx>
  • To: argyllcms@xxxxxxxxxxxxx
  • Date: Mon, 08 Aug 2016 09:44:53 +0000

Hello,

I've just compiled 1.9.0 beta so as to get fix for recent NVidia driver
changes. I copied compiled binaries from bin into /usr/local/bin so they
get searched before the ones installed from fedora 24 distribution (in
/usr/bin). I didn't copy any other files. I'm guessing this is OK for all
the files the fedora package install in /usr/share/color/argyll/ref (such
as CIE_C.sp), but I don't know whether I need to do anything about the
files it install into /usr/lib64:

/usr/lib64/libargyll.so.0
/usr/lib64/libargyll.so.0.0.0
/usr/lib64/libargyllicc.so.0
/usr/lib64/libargyllicc.so.0.0.0
/usr/lib64/libimdi.so.0
/usr/lib64/libimdi.so.0.0.0

I can't see where these get built - they aren't in lib, and I tried a find
command from the source directory, but it didn't find anything. I'm hoping
it's OK.

Anyway, I tried

dispwin

and it seems to work OK. It does issue the warning message:

Dispwin: Warning - new_dispwin: Expected VideoLUT depth 11 doesn't match
actual 10

I'm guessing this is harmless.

Other related posts: