[argyllcms] Colprof can't find black point

  • From: Graham White <g.graham.white@xxxxxxxxx>
  • To: argyllcms@xxxxxxxxxxxxx
  • Date: Sun, 03 Aug 2014 14:59:07 +0100

I am using the Argyll CMS tools to create printer profiles on my system
(64 bit Ubuntu 14.04). I have
two versions of Argyll: the version from Pascal de Bruijn's ppa, and the
version from the zipfile of compiled
binaries on the Argyll site (from here
http://www.argyllcms.com/Argyll_V1.6.3_linux_x86_64_bin.tgz).
Both of these are derived from the Argyll 1.6.3 source code.

When I run colprof on my data, the Argyll site binaries do fine, whereas
the
de Bruijn ppa version cannot find the black point. Here is a diff of the
two log files (Argyll site first,
then de Bruijn):

< Black point XYZ = 0.005508 0.005569 0.004623, Lab = 5.030863 0.558636
-0.053472
---
> Black point XYZ = -nan -nan -nan, Lab = -nan -nan -nan

This does not cause colprof to crash, but if you make it do something
which causes it to use
the blackpoint (for example, using a source profile with -S ) then it
segfaults.

This happens only with CMYK profiles: RGB profiles are fine.

Here is the output of the file command on the colprof binaries. De Bruijn:

/usr/bin/colprof: ELF 64-bit LSB  executable, x86-64, version 1 (SYSV),
dynamically linked (uses shared libs), for GNU/Linux 2.6.24,
BuildID[sha1]=6c02994f0d988ad0a344e07e57ac9fd754a38c76, stripped

and the Argyll site version:

/home/graham/src/Argyll_V1.6.3/bin/colprof: ELF 64-bit LSB  executable,
x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for
GNU/Linux 2.6.9,
BuildID[sha1]=dbebe424ed2b8d2f66fe8244082fb4c7ea7cec8c, not stripped

There seems to be very little difference apart from the kernel versions
that they are compiled against.

Any thoughts? Is this a symptom of other faults with the ppa version?

Thanks

Graham White
http://www.eecs.qmul.ac.uk/~graham/








Other related posts: