[argyllcms] Re: Argyll and SpyderPrint Lab data

  • From: Alexey Gribunin <Gribunin@xxxxxxx>
  • To: Владимир Топчий (Redacted sender bordac for DMARC) <dmarc-noreply@xxxxxxxxxxxxx>, argyllcms@xxxxxxxxxxxxx
  • Date: Fri, 23 Aug 2019 18:22:20 +0300

Hello Vladidmir!

There should be reference RGB values too for testform you used to print.

Like here:
======================
...
NUMBER_OF_FIELDS 7
BEGIN_DATA_FORMAT
SAMPLE_ID RGB_R RGB_G RGB_B LAB_L LAB_A LAB_B
END_DATA_FORMAT

NUMBER_OF_SETS 918
BEGIN_DATA
1 0 0 0 3.54 0.16 -1.10
2 0 12.55 0 6.99 -4.04 -0.13
....
END_DATA
======================
Best regards,
Alexey Gribunin, UNIT Color Technologies, Moscow, Russia.

On 23/08/2019 17:15, Владимир Топчий (Redacted sender bordac for DMARC) wrote:

Hello everybody.
I'm trying to build profile by Argyll using Spyder Print measurements data 
(Lab).

I extracted and prepared Lab value from SpyderPrint xml file and encapsulate it 
to a .ti3 Argyll file:

CTI3

DESCRIPTOR "Argyll Calibration Target chart information 3"
ORIGINATOR "Argyll printread"
CREATED "Tue Aug 20 19:16:40 2019"
DEVICE_CLASS "OUTPUT"
COLOR_REP "iRGB_LAB"

NUMBER_OF_FIELDS 7
BEGIN_DATA_FORMAT
SAMPLE_ID LAB_L LAB_A LAB_B
END_DATA_FORMAT

NUMBER_OF_SETS 441
BEGIN_DATA
1 25.13 10.5 14.31
2 24.51 21.49 -2.15
3 21.54 -24.67 -17.43
....
END_DATA


but when i trying to build profile by command:
colprof -v -D"Description" -qm -S AdobeRGB.icm -cmt -dpp MyTi3File

I get error:
colprof: Error - Input file doesn't contain field RGB_R

How to build RGB data from Lab or how make profile without thise RGB data?

Thank You for answer.


Other related posts: