[wdmaudiodev] Re: stereo and mono channels

1st Thanks Uwe for responding.
2nd I forgot to mention that this is for recording->you can't really
do anything on playback as it opens a stereo channel even if you play
mono channel. So the problem is recording->it opens 1 channel with stereo
flags???

Waldemar


UK>  Waldemar Haszlakiewicz schrieb:

UK> Hi guysI have a small problem here:

UK> I have just added mono support to our driver ->done a test in
UK> Wavelab and dwChannelMask is still set to KSAUDIO_SPEAKER_STEREO.
UK> nChannels gets 1 as supposed to, but now how should I know which
UK> channel to open if it still wants to open a stereo channel?

UK> Is there a default one->like left or is there something else here?

UK> Waldemar
UK>  



UK> Hallo Waldemar,
UK> our DIGI96 driver outputs the mono stream from the app on both channels.
UK> Someone told me that this is what the users expect, but I'm not really
UK> sure about that.
UK> Another possibility: To add a device to access the second mono channel.
UK> Uwe******************

UK> WDMAUDIODEV addresses:
UK> Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
UK> Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
UK> Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
UK> Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

UK> URL to WDMAUDIODEV page:
UK> http://www.wdmaudiodev.de/ 

******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.de/

Other related posts: