[THIN] Re: access denied when accessing citrix through web interface

I could be wrong, as I'm not too familiar with the guts of WI, but I am
pretty sure it will use NTLM.

 

What do you currently have configured? Explicit NT Auth? You've got your
Domain name in there also?

 

  _____  

From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On Behalf
Of Lara Adianto
Sent: Monday, September 13, 2004 6:50 AM
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: access denied when accessing citrix through web
interface

 

Ya, I didn't allow anonymous....I've changed it, now I allow anonymous, so I
can see the citrix logon.asp without having to authenticate. But I still
can't see the shared apps....same error msg after trying to login with my
username and password:

 

ERROR: The Citrix MetaFrame servers cannot process your request at this
time. The Citrix MetaFrame servers sent HTTP headers indicating that an
error occurred. 401 Access Denied 

 

No, I'm not using SSL yet, and I believe there's nothing wrong with the XML
port. If I enable desktop credential pass-through, what is the protocol used
for auth ? kerberos ? What if I'm using NT authentication ? will citrix
metaframe use kerberos protocol to authe to AD ? or NTLM ?

Thanks !

lara
"Lambert, Ryan" <rlambert@xxxxxxxxxxxxxxx> wrote:

Lara,

 

It sounds to me like youre not allowing anonymous access to the website.
May want to check in the security tab in IIS again just to confirm.

 

Couple of questions:

 

1.      I know your URL says http://  but, are you using SSL anywhere in
this setup?
2.      Can you verify all of your Citrix servers are running on the same
XML port?

 


  _____  


From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On Behalf
Of Lara Adianto
Sent: Friday, September 10, 2004 8:09 AM
To: thin@xxxxxxxxxxxxx
Subject: [THIN] access denied when accessing citrix through web interface

 

Hi list,

 

Does anyone know how to debug this problem:

I had citrix metaframe xp 3.0 server installed in windows 2000 server, users
can access the shared apps through program neighbourhood, but not through
web interface.

As described in the web interface , user can access it throught
http://servername/Citrix/MetaFrameXP, however the browser prompts me with
the logon box asking for username, password and domain. After I enter the
username, password, I can see the citrix login page, but the metaframe xp
message center displays the following error:

 

ERROR: The Citrix MetaFrame servers cannot process your request at this
time. The Citrix MetaFrame servers sent HTTP headers indicating that an
error occurred. 401 Access Denied 

 

My questions:

1. How can I disable the browser pop-up logon dialog box ? I believe I
should be able to see the citrix default login page directly without having
to authenticate through the browser first right ?

2. How can I debug the 401 Access denied problem ? I have tried enabling /
disabling various IIS authentication, without any success.

 

Thanks,

lara



----------------------------------------------------------------------------
-------- 
La vie, voyez-vous, ca n'est jamais si bon ni si mauvais qu'on croit
- Guy de Maupassant -
----------------------------------------------------------------------------
--------

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



----------------------------------------------------------------------------
-------- 
La vie, voyez-vous, ca n'est jamais si bon ni si mauvais qu'on croit
- Guy de Maupassant -
----------------------------------------------------------------------------
--------

  _____  

Do you Yahoo!?
Shop
<http://shopping.yahoo.com/b:Back%20to%20School%20Sale%202004:96644124;_ylc=
X3oDMTE0ZThra2w0BF9TAzk2Njg2MzU4BHNlYwNpbnRlZwRzbGsDbWFpbGZvb3Rlcg-->  for
Back-to-School deals on Yahoo! Shopping.

Other related posts: