[THIN] KB: CTX112420 - I/O Error or Cannot Connect to Citrix Server with an Application Using Accented Characters (For Example, é or è) in its Name

  • From: "Jim Kenzig ThinHelp.com" <jkenzig@xxxxxxxxx>
  • To: THIN <thin@xxxxxxxxxxxxx>
  • Date: Sun, 11 Mar 2007 15:49:01 -0400

CTX112420 - I/O Error or Cannot Connect to Citrix Server with an Application
Using Accented Characters (For Example, é or è) in its Name

This document was published at: http://support.citrix.com/article/CTX112420

Document ID: *CTX112420*, Created on: Mar 6, 2007, Updated: Mar 7, 2007

Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000


*Symptoms*

An application with accented characters (for example, é or è) in its name
does not launch correctly.

*Cause*

Under certain circumstances, the XML Service on the zone data collector uses
a different character encoding than the client. This results in the XML
Service translating the accented characters and passing the translated
characters to IMA to find the server with the smallest load, which fails
because the application name is now incorrect.

The CTXXMLSS.txt file, which is located in the *C:\Program
Files\Citrix\System32* folder, is used to set the encoding used by the XML
Service. If the XML Service is running separately to the World Wide Web
service, this file is read at connection time. If the file is not found, the
XML Service defaults to Unicode Transformation Format (UTF)-8 encoding.

*Resolution*

Ensure that the CTXXMLSS.txt file is present and configured correctly in the
*C:\Program Files\Citrix\System32* folder.


--
Jim Kenzig
Microsoft MVP - Terminal Services
http://www.thinhelp.com
Citrix Technology Professional
Provision Networks VIP
CEO The Kenzig Group
http://www.kenzig.com
Blog: http://www.techblink.com

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