[THIN] KB: CTX109626 - IMA Service Fails to Start with Error Code 2147876922
- From: "Jim Kenzig http://ThinHelp.com" <jkenzig@xxxxxxxxx>
- To: thin@xxxxxxxxxxxxx
- Date: Sat, 30 Sep 2006 13:18:32 -0700 (PDT)
CTX109626 - IMA Service Fails to Start with Error Code 2147876922
This document was published at: http://support.citrix.com/article/CTX109626
Document ID: CTX109626, Created on: Jun 5, 2006, Updated: Sep 29, 2006
Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000, Citrix MetaFrame
XP 1.0 for Microsoft Windows 2003
Symptoms
After upgrading from MetaFrame XP Feature Release 3 / Service Pack 3 to
Service Pack 4, the IMA Service fails to start with error code 2147876922.
Errors in the Event Viewer:
Event ID 7024 -The Independent Management Architecture service terminated
with service-specific error 2147876922 (0x8006003A).
Event ID 3601-Failed to load initial plugins with error
IMA_RESULT_DB_TABLE_NOT_FOUND
Event ID 3609-Failed to load plugin Imaadminss.dll with error
IMA_RESULT_DB_TABLE_NOT_FOUND
HKLM\Software\Citrix\IMA\Runtime\ CurrentlyLoadingPlugin - Imaadminss.dll
Cause
During the upgrade, the ?OnKeyTableDelete(dbo)? trigger was added to the
KEYTABLE table in the data store.
Resolution
Delete the triggers from the KEYTABLE in the database:
1. Right-click the KEYTABLE and select Design Table.
2. In the design table window, click the Triggers button.
3. From the Trigger properties window in the ?Name:? drop-down box, delete
both OnKeyTableDelete(dbo) and OnKeyTableInsertUpdate(dbo) triggers.
More Information
CTX107323 ? Unable to Delete Objects from the Citrix Management Console
Jim Kenzig
Microsoft MVP - Terminal Services
Provision Networks VIP
CEO The Kenzig Group
http://www.kenzig.com
Blog: http://www.techblink.com
Terminal Services Downloads: http://www.thinhelp.com
Other related posts: