[THIN] KB: CTX106313 - Cannot Launch More Than One Internet Explorer After Service Pack 4 Install
- From: "Jim Kenzig Kenzig.com" <jkenzig@xxxxxxxxx>
- To: thin@xxxxxxxxxxxxx
- Date: Thu, 30 Jun 2005 04:49:21 -0700 (PDT)
CTX106313 - Cannot Launch More Than One Internet Explorer After Service Pack 4
Install
This document was published at:
http://support.citrix.com/kb/entry.jspa?externalID=CTX106313
Document ID: CTX106313, Created on: Jun 29, 2005, Updated: Jun 30, 2005
Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000, Citrix MetaFrame
XP 1.0 for Microsoft Windows 2003
Symptoms
When a Published Desktop is launched and there is an open Internet Explorer,
trying to open an .htm or .html file while the other Internet Explorer is still
open does not work. If the first instance of Internet Explorer is closed and no
other Internet Explorer is open, the .htm or .html files open without a problem.
In this particular situation Content Re-Direction is NOT enabled.
You will also notice that the default shortcut of Internet Explorer changes.
Cause
This issue appears when Citrix MetaFrame XP Service Pack 4 is installed.
Uninstalling Service Pack 4 does not solve the issue.
Resolution
Change the following registry entry on all of the MetaFrame Service Pack 4
servers.
Changing the registry entry to the original path works, but only until the
server is rebooted and then it is changed back to the Service Pack 4 registry
key.
WARNING: Using Registry Editor incorrectly can cause serious problems that may
require you to reinstall your operating system. Citrix cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be solved. Use
Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys and
Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete
Information in the Registry" and "Edit Registry Data" Help topics in
Regedt32.exe. Make sure you back up the registry before you edit it. If you are
running Windows NT, also update your Emergency Repair Disk (ERD).
Original Key before Service Pack 4 Install:
HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command
Value: "C:\Program Files\Internet Explorer\iexplore.exe" %1
Key after Service Pack 4 Install:
HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command
Value: "C:\Programme\Citrix\system32\iexplore.exe" %1
Change the registry to the following:
Workaround Key:
HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command
Value: "C:\Programme\Citrix\system32\iexplore.exe" "%1"
In the workaround key, the only change is the addition of quotation marks.
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