[tcb] Re: Empi accufire conversion kit

I called Empi. The guy told me that I had to push really hard on the wheel. He 
said he heard somepeople use a socket to force it down but he wouldnt recommend 
it cause it might split the wheel. He said I should try if at worst..taking a 
socket..and driving it down with my fingers. Empi rep said it's a real tight 
fit and possible massaging the cap would do the trick...I'll post the results 
after i get off work today...thanks for the help!
Dan Martin <danandkatrinamartin@xxxxxxx> wrote:MAKE sure the wheel is pushed 
ALL the way down. I had to press allot 
harder than I would think to get the wheel down on the shaft far enough 
to get the rotor back on.
Mine is a compu fire. I was pretty sure it was not going to work, I 
called Kermit (at ASK imports, where I purchased it) told him the 
problem I was having. He told me to push the wheel down on the shaft 
with a socket big enough to fit over the dizzy shaft and press on the 
wheel. I told him I was afraid to push any harder for fear of breaking 
it. He said to make sure it was lined up correctly and to push "real 
hard" and if it broke he would replace it. I pushed it down on there 
and now it works.
When I got the compu fire the only question was "with vac advance or 
not"
On Nov 14, 2004, at 7:43 PM, Lee Le wrote:

> I just tried to install the following kit//EMPI accufire conversion 
> kit//. I take the points out. Put the module in and bolt it. Put the 
> accufire rotor wheel in and install the stock rotor backon top of it. 
> For some reason the rotor wheel makes the rotor sit up a little too 
> high..I cant get the distributor cap on without trying to force it 
> down.
> I checked the wire guide that goes thru the distrubutor...installed 
> correctly. There is also no unnecessary gaps. Didn't use the spacer 
> proveded cause it's a mech advance dist. Possibilities? AM I supposed 
> to force the dist cap down? I took the accurfire rotor wheel out and 
> put just the old rotor back on..goes down perfectly. Then put the accu 
> fire wheel..back on..sitting flush with the dist shaft...and rotor 
> back on..still..wont let me put the cap on? Please help! ?? Condensor 
> was taken out too.
>
> 71 westy type 2 1600cc bosch dist.
>
> 
> ---------------------------------
> Do you Yahoo!?
> Check out the new Yahoo! Front Page. www.yahoo.com
>
>
>
Dan & Katrina Martin
1971 VW Bus
H.B.B.
T.C.B.




                        
---------------------------------
Do you Yahoo!?
 Check out the new Yahoo! Front Page. www.yahoo.com


Other related posts: