[slackintosh-users] Re: Slack 12 Upgrade

  • From: Adrian Ulrich <adrian@xxxxxxxxxxxxxxxx>
  • To: slackintosh-users@xxxxxxxxxxxxx
  • Date: Tue, 17 Jul 2007 20:51:31 +0200


> These are the following variables i have in my slapt-getrc
> SOURCE=http://slackintosh.workaround.ch/pub/slackintosh/12.0/patches
> SOURCE=http://slackintosh.workaround.ch/pub/slackintosh/12.0/extra
> SOURCE=http://slackintosh.workaround.ch/pub/slackintosh/12.0

Remove the /patches and /extra line. Slapt-get will pickup themself.

> My other issue which is more important, is that gcc doesn't seem to work.
> (On a quick sidenote, my upgrade path was basically using slapt-get to install
> glibc-solibs, aaa_base, aaa_elflibs, pkgtools, sed, glibc-*, a couple of
> other things, and gcc.)

So you did not run 'slapt-get --dist-upgrade' ? :-p

> $ echo 'int main(){}' > t.c; gcc -o t t.c
> /usr/lib/gcc/powerpc-slackware-linux/4.1.2/../../../../powerpc-slackware-linux/bin/ld:/usr/lib/gcc/powerpc-slackware-linux/4.1.2/../../../libc.so:
>  file 

What does 'file /lib/libc.so' tell you?

Are you running this on a biarch system?

 RFC 1925:
   (11) Every old idea will be proposed again with a different name and
        a different presentation, regardless of whether it works.

Other related posts: