RE: Cognos Problem with JAWS

I am using JAWS 11.  It will be great if JAWS 12 has some improvement in this 
area.  I believe more and more applications are going to the web and we need it 
to be as accessible as possible so we can contribute in the workplace.
 
Brent Neal
140 E 300 S
Salt Lake City, UT 84111
 
Programmer
Phone:  801.526.9797
Email:  bneal@xxxxxxxx 


>>> "Aubertin, Gerry" <gaubertin@xxxxxxxxxxxxxxxxxxxx> 9/15/2010 12:02 PM >>>
Brent:

   I don't know what version of Jaws you are using, but I was looking at the 
Freedom Scientific site and noticed one of the items mentioned in the What's 
New in Jaws 12 Public Beta, that looks that it might apply to you. The item 
seemed to be talking about problems with edit boxes in Web forms. I hope this 
helps you.

Gerry Aubertin
Programmer/Analyst
Phone: (519) 271-4840 Ext. 8807

CONFIDENTIALITY NOTICE - The contents of this message and the attachments are 
confidential and are for the exclusive use of the intended recipient(s). If you 
are not an intended recipient, please immediately delete it without reading it 
and without further distribution or disclosure.  Any further distribution of 
this message to others is subject to this Confidentiality Notice and/or any 
confidentiality agreement or non-disclosure agreement in effect that covers the 
information contained in the message and any attachments.





________________________________________
From: programmingblind-bounce@xxxxxxxxxxxxx 
[programmingblind-bounce@xxxxxxxxxxxxx] On Behalf Of Brent Neal 
[bneal@xxxxxxxx] 
Sent: Tuesday, September 14, 2010 5:45 PM
To: programmingblind@xxxxxxxxxxxxx 
Subject: Re: Cognos Problem with JAWS

I have not heard anything so far.  Sometimes when I go to a different report in 
the same session it works correctly then that one also stops working.  This is 
a strange problem.  There is a person from IBM Cognos who is coming to Utah and 
he said he will meet with me for a couple of hours on October 21 to talk about 
accessibility.  I hope some how I can get this figured out.

Brent Neal
140 E 300 S
Salt Lake City, UT 84111

Programmer
Phone:  801.526.9797
Email:  bneal@xxxxxxxx<mailto:bneal@xxxxxxxx>


>>> Dorene Cornwell <dorenefc@xxxxxxxxx> 9/14/2010 3:29 PM >>>
Hi Brent
Did you get any private replies to this?
To be honest, it sounds like your problem could EITHER be something with JAWS 
or something with Cognos. I say this because the problem occurs in two 
different versions of Explorer as well.
Once in awhile when someone posts a query like this, someone else will have 
suggestions for things to try related to the different JAWS cursors and I am a 
lousy source for anything like that.
Otherwise,you may need to get your own tech support on the phone with both 
Cognos and FS to figure out what the issues might be. I ask in a few different 
places about people using these tools with JAWS and my sense is there really 
are not a lot of people so you probably get to be on the bleeding edge of 
testing accessibility features.
For instance, is there some other way to enter things that go into formulas?
I am interested in what you figure out about this.
DoreneC
Seattle WA


On Tue, Sep 14, 2010 at 8:58 AM, Brent Neal 
<bneal@xxxxxxxx<mailto:bneal@xxxxxxxx>> wrote:
Our data warehouse team uses IBM Cognos to create reports for our users. The 
Report Studio is an internet application. I created a table inside the report 
and in one of the table cells I need to add a formula. To do this I go to query 
calculation and double click with the left mouse button. This brings up a 
pop-up edit box used to enter the name of the formula. Once I type the name and 
hit enter another pop-up edit box called expression definition pops up which is 
used to enter the code. This worked correctly for about 5 times then after that 
JAWS would no longer recognize it as an edit box. It still pops up but JAWS 
does not recognize it and does not allow a sighted user to type in it. A 
sighted user can copy and paste something in this box but cannot type. When we 
upgraded from IE6 to IE8 it worked correctly for about 5 or 6 more times then 
the same problem came up. I cannot think of anything I am doing different. Does 
anyone have any idea what JAWS could be doing to cause this problem and how to 
fix it? This is very important because this is where you type and modify the 
code.
Any suggestions are appreciated.
Thank You
Brent Neal
140 E 300 S
Salt Lake City, UT 84111
Programmer
Phone: 801.526.9797
Email: bneal@xxxxxxxx<mailto:bneal@xxxxxxxx>



__________
View the list's information and change your settings at 
http://www.freelists.org/list/programmingblind 

Other related posts: