Re: sqlplus connect string issue

Yes thats correct

--- On Tue, 30/6/09, LS Cheng <exriscer@xxxxxxxxx> wrote:


From: LS Cheng <exriscer@xxxxxxxxx>
Subject: Re: sqlplus connect string issue
To: "hrishy" <hrishys@xxxxxxxxxxx>
Cc: "Howard Latham" <howard.latham@xxxxxxxxx>, "oracle-l@xxxxxxxxxxxxx" 
<oracle-l@xxxxxxxxxxxxx>, "MarkBobak" <Mark.Bobak@xxxxxxxxxxxx>
Date: Tuesday, 30 June, 2009, 10:28 AM


Hi

Your local SQLPLUS is from 9i HOME? The HOME from which the database is running?

Thanks

--
LSC



On Tue, Jun 30, 2009 at 11:22 AM, hrishy <hrishys@xxxxxxxxxxx> wrote:






Hi
 
Yes this box has several oarcle homes.
 
On this box the database mysid is running from 9i oracle home, but the listener 
is from 10g oracle home.
 
 
 
regards
Hrishy

--- On Tue, 30/6/09, LS Cheng <exriscer@xxxxxxxxx> wrote:


From: LS Cheng <exriscer@xxxxxxxxx>

Subject: Re: sqlplus connect string issue
To: hrishys@xxxxxxxxxxx
Cc: "Howard Latham" <howard.latham@xxxxxxxxx>, "oracle-l@xxxxxxxxxxxxx" 
<oracle-l@xxxxxxxxxxxxx>, "MarkBobak" <Mark.Bobak@xxxxxxxxxxxx>
Date: Tuesday, 30 June, 2009, 6:20 AM



Hi

Are your databases running from several ORACLE_HOME?

Can you do ps -ef | grep pmon | grep mysid and look from which ORACLE_HOME is 
mysid running?

Thanks

--
LSC






On Tue, Jun 30, 2009 at 6:16 AM, hrishy <hrishys@xxxxxxxxxxx> wrote:






Hi All
 
Database mysid is running on localhost
 
tnsping mysid
Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (COMMUNITY = 
tcp.world) (PROTOCOL = TCP) (Host = remotehost.com) (Port = 1522))) 
(CONNECT_DATA = (SID = mysid)))
OK (0 msec)
 
database spfile says its registered on a listener that is running on port 1527
if do a show parameter listener on the database
 
There is a non default named listener running on localhost on port 1527 which 
is a 10g listener.  

regards
Hrishy
--- On Mon, 29/6/09, Howard Latham <howard.latham@xxxxxxxxx> wrote:


From: Howard Latham <howard.latham@xxxxxxxxx>
Subject: Re: sqlplus connect string issue 

To: hrishys@xxxxxxxxxxx
Cc: "oracle-l@xxxxxxxxxxxxx" <oracle-l@xxxxxxxxxxxxx>, "MarkBobak" 
<Mark.Bobak@xxxxxxxxxxxx>
Date: Monday, 29 June, 2009, 3:38 PM 






Can you do a tnsping ahnd post the results
?


2009/6/29 hrishy <hrishys@xxxxxxxxxxx>






Hi Mark
 
Nope TWO_TASK is not set.
 
regards
Hrishy

--- On Mon, 29/6/09, Bobak, Mark <Mark.Bobak@xxxxxxxxxxxx> wrote:


From: Bobak, Mark <Mark.Bobak@xxxxxxxxxxxx>
Subject: RE: sqlplus connect string issue
To: "hrishys@xxxxxxxxxxx" <hrishys@xxxxxxxxxxx>, "oracle-l@xxxxxxxxxxxxx" 
<oracle-l@xxxxxxxxxxxxx>
Date: Monday, 29 June, 2009, 10:22 AM 





If the TWO_TASK environment variable is not set, then a login w/ 
username/password will connect to the local database running out of 
$ORACLE_HOME and identified by $ORACLE_SID.

If the TWO_TASK environment variable is set, then a login w/ username/password 
will connect to a database identified by connect string with the value of 
$TWO_TASK.  In other words, it's the same as typing username/password@$TWO_TASK.

Note that if TWO_TASK is set, it will always override ORACLE_SID.

Hope that helps,

-Mark
________________________________________
From: oracle-l-bounce@xxxxxxxxxxxxx [oracle-l-bounce@xxxxxxxxxxxxx] On Behalf 
Of hrishy [hrishys@xxxxxxxxxxx]
Sent: Monday, June 29, 2009 5:09
To: oracle-l@xxxxxxxxxxxxx
Subject: sqlplus connect string issue

Hi

For one of my databases i am unable to connect using
sqlplus user/password
but when i try
sqlplus 
username/password@connect-string<mailto:username/password@connect-string>  it 
connects

The error message i get using sqlplus username/password is
ORA-01017: invalid username/password; logon denied

There are many other databases on this server and they work fine.
The thing that is different about this database is

The tnsnames.ora has an entry for this database pointing to another host on 
port 1522.
The local listener parameter on the database says the database is registered 
for a listener on port 1527

i did a truss -o log sqlplus username/password but clueless on what i should 
look or fix so i can connect using just sqlplus username/password without the 
connection string.

regards
Hrishy










-- 
Howard A. Latham









      

Other related posts: