Re: help trying to clone database to remote server

On 4/13/05, Paula_Stankus@xxxxxxxxxxxxxxx <Paula_Stankus@xxxxxxxxxxxxxxx> w=
rote:
> =3D20
> I am getting the following error:
>=20
> RMAN-00571: =3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D=
3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D=
3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D
> RMAN-00569: =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=
=3D3D=3D3D=3D3D ERROR MESSAGE =3D
> STACK FOLLOWS =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3=
D=3D3D=3D3D=3D3D
> RMAN-00571: =3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D=
3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D=
3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D
> =3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D=3D3D
> RMAN-03002: failure of Duplicate Db command at 04/13/2005 14:50:39
> RMAN-03015: error occurred in stored script Memory Script
> ORA-19507: failed to retrieve sequential file,
> handle=3D3D"df_LEPROD_s1597_p1_htghnp
> ds_1_1", parms=3D3D""
> ORA-27029: skgfrtrv: sbtrestore returned error
> ORA-19511: Error received from media manager layer, error text:
>    nwora_open_restore: Could not locate the NWORA save file
> 'df_LEPROD_s1597_p1_
> ht
> ghnpds_1_1' on server 'dohsbus01'.
>=20
> Here is a sample of my script:
>=20
> BACKS=3D3D/usr/oracle/tools/backups;export BACKS
> . /usr/oracle/tools/ids
> umask 066;export umask
> RSCRPT=3D3D$BACKS/storscripts;export RSCRPT
> #export NLS_LANG=3D3DAMERICAN_AMERICA.WE8ISO8859P1
> NSR_CLIENT=3D3Ddohsdb10.test;export NSR_CLIENT
> NSR_SERVER=3D3Ddohsbus01;export NSR_SERVER
> ORATAB_LOC=3D3D/var/opt/oracle;export ORATAB_LOC
> #$ORACLE_HOME/bin/rman msglog /dblogs/backups/dupleprod.txt<< EOD
> $ORACLE_HOME/bin/rman << EOD
> connect rcvcat $RMANID
> connect target $TARGET@xxxxxxxxxxxxxxxxxxxxxx
> connect auxiliary $AUX@xxxxxxxxxxxxxxxxxxxxxxxxxx
> run {
> allocate auxiliary channel d1 type 'SBT_TAPE' ;
> set newname for datafile 1 to '/u01/oradata/leprod/system01.dbf';
> set newname for datafile 2 to '/u01/oradata/leprod/undo01.dbf';
> set newname for datafile 4 to '/u02/oradata/leprod/ax_le_small01.dbf';
> set newname for datafile 5 to '/u01/oradata/leprod/users01.dbf';
> set newname for datafile 3 to '/u02/oradata/leprod/at_le_small01.dbf';
> #execute script archive_log_current;
> #execute script backup_al_all;
> duplicate target database to leprod
>=20
> ....................................
> --
> http://www.freelists.org/webpage/oracle-l
>=20

Hi,

You need to further configure the auxiliary channel so that it can
access the backup sets created on your NW server for the *production*
node.

With your simple
> allocate auxiliary channel d1 type 'SBT_TAPE' ;
I guess the default sbt configuration for your test "node" is used,
thus causing NW to look for backup sets that might have been created
for this test "node", and there aren't any.

Regards,
Jerome
--
http://www.freelists.org/webpage/oracle-l

Other related posts: