Re: Oracle AQ Question

>>>>>
I still can't get the aq to propagate.  I have a propagation scheduled and a 
subscriber.  But the job never runs.  I found the below in a trace file.  This 
shouldn't have anything to do with what I'm trying to do.  131, 52 is the 
session id for the schedule.
 
*** SESSION ID:(131.44) 2010-03-16 09:44:40.683
kwqjschupd: schedule not found, unschedule assumed 
 
 
What do you need to make the schedule actually execute?  I have one schedule 
that I left up since last Friday.  It has no failures, no last error date, and 
no error messages.
 
I've tried running the associated job with dbms_job.run.  It gave no errors; it 
just didn't run.  I tired resetting the interval to 1 sec -- nothing.  Nulls in 
the LATE_DATE and NEXT_DATE is well in the past.  I have 20 job_queue_processes 
and 4 aq_tm_processes.<<<<

I'm not sure if this is related to your situation, but I've been trying to get 
streams to work over SSL.  I was having an issue with the propagation process 
dying after trying to push through large LOB transaction to the remote site.  
I'm on RHAS 4u7 x86_64 bit with 10.2.0.4.  Support finally found that I was 
hitting a bug for which they provided me with a patch which seems to have 
resolved the propagation issue.

They also said that if I was in a streams environment to apply the following 
patches:
5609854
5933656
6640411
6827260
7033630
7219752
7579469
7599054
8221870
8292378
And the one that really fixed the propagation issue was...
7118478

There is also a metalink note 437838.1 which lists the streams specific 
patches.  I know I mention streams but streams also uses AQ so their might be a 
link here.

hth

--
mohammed


      

Other related posts: