Oracle 10201 on redhat5 32bit

Hi list,

I am trying to install the subj and it fails with the following error:

oracle@zimmer database]$ ./runInstaller -paramFile /tmp/oraparam.ini
Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, SuSE-9, redhat-4,
UnitedLinux-1.0, asianux-1, asianux-2 or redhat-5
                                      Passed


All installer requirements met.

Preparing to launch Oracle Universal Installer from
/tmp/OraInstall2010-04-30_09-40-45AM. Please wait
...[oracle@zimmerdatabase]$ Oracle Universal Installer, Version
10.2.0.1.0 Production
Copyright (C) 1999, 2005, Oracle. All rights reserved.

*Exception java.lang.UnsatisfiedLinkError:
/tmp/OraInstall2010-04-30_09-40-45AM/jre/1.4.2/lib/i386/libawt.so:
libXp.so.6: cannot open shared object file: No such file or directory
occurred..*
java.lang.UnsatisfiedLinkError:
/tmp/OraInstall2010-04-30_09-40-45AM/jre/1.4.2/lib/i386/libawt.so:
libXp.so.6: cannot open shared object file: No such file or directory

I checked if the package is installed, it looks like it is:

[root@zimmer ~]# yum provides libXp.so.6
Loaded plugins: rhnplugin, security
libXp-1.0.0-8.i386 : X.Org X11 libXp runtime library
Repo        : rhel-i386-server-5
*Matched from:
Other       : libXp.so.6
*


libXp-1.0.0-8.1.el5.i386 : X.Org X11 libXp runtime library
Repo        : rhel-i386-server-5
*Matched from:
Other       : libXp.so.6

*

[root@zimmer ~]# rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}
(%{ARCH})\n" | grep libXp
*libXpm-3.5.5-3 (i386)*


I am not really clear why the versions of the packages differ in yum in rpm
-q, but at least it is obvious that the package is on the place.

Has anybody seen something like that? Did you manage to fix it??

Please, share your knowledge.

Thanks before hand,
Masha

Other related posts: