RE: 10gR2 no longer installs on non-supported Linux

Just took myself up on my own suggestion and modified the db_prereq.xml file to 
have the GLIBC dependency treated as a Warning, not an Error. This resulted in 
a successful custom install (w/o Enterprise Edition components and w/o XML 
Developer component) on my SuSE 9.1 (no errors in make.log), which it would 
refuse to do before the modification: my glibc is 2.3.2-88 instead of the 
"required" 2.3.3 because, if I upgrade it, my WMWare Workstation 2.0.4 stops 
working and I have to install Windows on my home machine natively.

Creating a database with dbca errored out initially because my libaio wasn't at 
least 0.3.96, but is running fine (it's now in the catalog creation stage) 
after I upgraded to 0.3.98.

Max Pakhutkin 


-----Original Message-----
From: oracle-l-bounce@xxxxxxxxxxxxx
[mailto:oracle-l-bounce@xxxxxxxxxxxxx]On Behalf Of Pakhutkin, Maxim
(Max)
Sent: Tuesday, July 19, 2005 2:13 PM
To: oracle-l@xxxxxxxxxxxxx
Subject: RE: 10gR2 no longer installs on non-supported Linux


You might want to experiment with modifying the XML files in the 
database/stage/prereq directory of the 10.2.0.1 distribution. For example, 
db/db_prereq.xml contains the following line:

        <PREREQUISITEREF NAME="GLIBC" SEVERITY="Error"/>

Changing that to "Warning" might help you to continue the installation. 
Needless to say, doing that wouldn't guarantee that the linking stage of the 
process will succeed.

Max Pakhutkin 

-----Original Message-----
From: oracle-l-bounce@xxxxxxxxxxxxx
[mailto:oracle-l-bounce@xxxxxxxxxxxxx]On Behalf Of Jesse, Rich
Sent: Monday, July 18, 2005 5:39 PM
To: oracle-l@xxxxxxxxxxxxx
Subject: 10gR2 no longer installs on non-supported Linux


Anyone else able to get 10gR2 installed on a non-supported Linux like
Gentoo (for testing purposes only, obviously)?  I haven't yet done a:

        strace -o /tmp/orainstall -f -ff ./runInstaller
-ignoreSysPrereqs

...and checked out the 80+ files created about this, but the Installer
fires up a "Product-Specific Prerequisite Check" even with the
-ignoreSysPrereqs and the requirements for glibc and others fail.  I
believe I meet the glibc minimum at 2.3.2, but the installer refuses to
continue.  And thanks to the Gentoo development, I'm unable to upgrade
my glibc because they delete ebuilds from portage and a revdep rebuild
will fail.  <sigh>  Really need to dump Gentoo -- gone WAAAY downhill
since Daniel Robbins left.

BTW, this is my desktop, and I'm running a 2.6.8-gentoo-r3 kernel on a
2.6Ghz P-IV w/1G RAM.

TIA!
Rich
--
http://www.freelists.org/webpage/oracle-l
--
http://www.freelists.org/webpage/oracle-l
--
http://www.freelists.org/webpage/oracle-l

Other related posts: