Hi Philippe, The BTrack object is not the same as the BMediaTrack object, and likewise I hadn't planned on making the BExtractor the same as the BMediaExtractor object. The BMedia* versions are the ones that applications typically use and encapsulate some handy shortcuts or other functionality that most every application will use. The other versions are the API that is implemented by the addons. The point is well taken though. Since these are the APIs that will be implemented by addons fulfilling these roles, perhaps we could use BMediaExtractorAddon, etc. That would read better too: I need to implement a media extractor addon for avi. :-) Then we could have instantiate_extractor_addon(). ;-) (to those in the know) Andrew P.S. the original media kit names were really BExtractor, etc., but we don't have to play by those rules where this is concerned, since they were in the private namespace. -----Original Message----- From: "Philippe Houdoin" <philippe.houdoin@xxxxxxx> To: openbeosmediakit@xxxxxxxxxxxxx Date: Mon, 2 Sep 2002 08:38:03 +0200 (added by postmaster@xxxxxxxxxx) Subject: [openbeosmediakit] Re: new version of Extractor.h Hi Andrew, Please don't call these classes simply BTrack, BExtractor and BWriter, that's far too general. BMediaTrack, BMediaExtractor and BMediaWriter looks all fine. If calling them differently from BeOS MediaKit ones is necessary, then why not only remove the B prefix? - Philippe, back to lurkeland now. -- Fortune Cookie Says: Adolescence, n.: The stage between puberty and adultery.