[openbeosmediakit] Re: media adds on

  • From: Marcus Overhagen <marcusoverhagen@xxxxxxxx>
  • To: openbeosmediakit@xxxxxxxxxxxxx
  • Date: Thu, 12 Jul 2007 14:27:21 +0200 (CEST)

Salvatore Benedetto wrote:

> In order to have the media_addon loaded, it has to placed under
> /boot/beos/system/add-ons/media right? Apparently the only media

no, you should place it in /boot/home/config/add-ons/media

> add ons that gets loaded is the mixer, while the usb_webcam is not longer
> loaded even if it's there. Since it used to get loaded, before I started
> coding it,

err sorry, how did you do that?

> I need to know why it doesn't get loaded anymore,  and for that I need its,
> or the media_server, debug info. :)

On BeOS and Zeta, appeareantly only nodes the mixer node, and one
node thas has physical outputs and is connected to the mixer get
Additionally, nodes that return true from WantsAutoStart() are also
instantiated. Be careful, the BeBook documents the function signature 
wrong, it must be:
virtual bool WantsAutoStart();

For Haiku, this comment should describe what happens. Contrary to R5,
it will instantiate all physical input/outputs.

        // During startup, first all add-ons are loaded, then all
        // nodes (flavors) representing physical inputs and outputs
        // are instantiated. Next, all add-ons that need autostart
        // will be autostarted. Finally, add-ons that don't have
        // any active nodes (flavors) will be unloaded.


Viel oder wenig? Schnell oder langsam? Unbegrenzt surfen + telefonieren
ohne Zeit- und Volumenbegrenzung? DAS TOP ANGEBOT JETZT bei Arcor: günstig
und schnell mit DSL - das All-Inclusive-Paket für clevere Doppel-Sparer,
nur  39,85 ?  inkl. DSL- und ISDN-Grundgebühr!

Other related posts: