[openbeosmediakit] Re: media adds on

  • From: "Salvatore Benedetto" <emitrax@xxxxxxxxx>
  • To: openbeosmediakit@xxxxxxxxxxxxx
  • Date: Thu, 12 Jul 2007 14:11:42 +0200

On 7/12/07, Stephan Assmus <superstippi@xxxxxx> wrote:

Another way to see some output is to quit the already running
and launch a new instance in a terminal. You should also see the output
from the nodes that are loaded by the addon server, because that one is
started by the media_server, so it's output should also be routed to the

That's a start. I see the media_server messages, but not the nodes one. The
messages I get regarding the usb_webcam media addon is

NodeManager::RegisterAddon:: ref-name "usb_webcam.media_addon", assigning id

but I don't see the messages of the addon itself, which contains two webcam

> Is there any documentation about media addons development or something
> close?

AFAIK, only what is in the BeBook. I think there is a virtual function
"WantsAutoStart()" or something. And you can specify if your node is a
"Physical" Input/Output. That might help too.

I know media node development can be challenging, particularily because
documentation is sparse. Your best bet is to look at the existing nodes in
the Haiku tree. Those were either done by knowledgable people and/or are
based on sample code from Be. So they provide the most up to date
"documentation" you can get.

The problem is that I'm totally new to both the media_server and addons.
see if I can gather some info by looking at other working code.

My main concern though , was to understand why my webcam doesn't appear
anymore in the media window under video, so I can fix the code I added.

Best regards,


Salvatore Benedetto (a.k.a. emitrax)
Student of Computer and Telecommunications Engineering
University of Messina (Italy)

Siti di vera informazione Italiana

Please do not send me any word, excel or power point file

Other related posts: