[kismac] Re: [bug ?] Saving filtered list

  • From: Geoffrey Kruse <gkruse@xxxxxxxxxxxxxx>
  • To: kismac@xxxxxxxxxxxxx
  • Date: Sat, 4 Feb 2006 16:07:30 -0700

On Feb 4, 2006, at 3:58 PM, themacuser wrote:

Ok, I'll make it a svn diff next time, once i figure out how to do that.
Thanks for looking at it.

No problem. Just run svn diff from the root kismac directory and it will spit the patch out.


On 05/02/2006, at 9:25 AM, Geoffrey Kruse wrote:

Now that I have commit access I will take a look at this. :) Also, now that we have trac, its a good idea to submit all patches there as a ticket so they don't get lost. It is best if you can create a patch using svn diff and attach it to the ticket.

Thanks and keep the code coming,


On Feb 4, 2006, at 3:32 PM, themacuser wrote:

Do we think this is a useful fix? Is it going into r78?
On 04/02/2006, at 9:56 PM, themacuser wrote:

Bug squashed / feature removed.
Grab the modified files from here: http://gm2.ath.cx/~gm/ kmbugfix1.zip

I don't like this as a "feature" as you don't really ever need to save a list of filtered APs. Filtering them accidentally causes a loss of data like globo's problem.

My rule for determining bug/feature is:
If it gets in the way more than it's a good thing, then it's a bug.
If it is a good thing more than it's a bad thing, it's a feature.

On 04/02/2006, at 8:47 PM, themacuser wrote:

I've reproduced it, and am now working on fixing it.
On 04/02/2006, at 10:40 AM, themacuser wrote:

Hmmm, I'll investigate this one.

We do need something like bugtraq here though to keep track of these.
On 04/02/2006, at 12:35 AM, globo wrote:


Last night I was out trying to find a few new APs on a route that I've
not been on. All worked well. I was carrying my PB in my bag with the
GPS-USB cable stuck between the screen and keybord. That way it won't
go into sleepmode while having a defcto closed PB. The cable sometimes
"presses" a key on the keyboard though. That happened last night. The
letter "m" got into the Searchbox on the top-right side. No big deal I
thought and saved my new found APs - I THOUGHT.

What happened is this: KISMAC saved all APs that contained the letter
"m" in its SSID. It dind NOT save all others.

Is it a bug or a feature? Thank god I exported a NetStumbler File for
WIGLE last night so only one day was lost.

Are you able to reproduce that same behaviour? If so I'd call this a
serious bug since large amounts of data are lost.


Other related posts: