[kismac] Sitecom wl-022 prism3

  • From: Zeno <recurse@xxxxxxxxxxx>
  • To: <kismac@xxxxxxxxxxxxx>
  • Date: Sat, 26 Jun 2004 16:01:09 +0200

Hello,

I've just bought a sitecom wl-022 usb wifi dongle. It has a prism3 chipset
(I think), and following the instructions on
http://astro.temple.edu/~moshe/intersil/ I got it to work under osx.

The problem is that it won't work with kismac. Here's the output of
console.log:

---------------------------------------------------------------------------
2004-06-26 15:10:28.725 KisMAC[421] KiMAC startup done. Homedir is
/Applications/KisMAC.app NSAppKitVersionNumber: 743.200000

2004-06-26 15:10:28.885 KisMAC[421] GPS integration disabled

kextunload: unload kext /System/Library/Extensions/Intersil Prism2.kext
succeeded

2004-06-26 15:10:38.789 KisMAC[421] found device i didn't want (vendor =
0x5ac, product = 0x8006)

2004-06-26 15:10:38.793 KisMAC[421] found device i didn't want (vendor =
0x5ac, product = 0x8005)

2004-06-26 15:10:38.797 KisMAC[421] found device i didn't want (vendor =
0x9016, product = 0x182d)

2004-06-26 15:10:38.809 KisMAC[421] found device i didn't want (vendor =
0x5ac, product = 0x8005)

2004-06-26 15:10:38.813 KisMAC[421] found device i didn't want (vendor =
0x5ac, product = 0x8203)

2004-06-26 15:10:38.816 KisMAC[421] found device i didn't want (vendor =
0x5ac, product = 0x8005)

2004-06-26 15:10:52.193 KisMAC[421] Restarting the USB drivers
---------------------------------------------------------------------------

The vendor and product ids reported by systemprofiler are 6189 ($182d) and
36886 respectively.

Now i've tried to fiddle with the kismac cvs sources to see if I can fix
this myself, but compilation fails because it can't find
"CoreServices/CoreServices.h". I did change the cross-develop sdk (as
suggensted on the wiki), to no avail.

Am I missing something here?
Any help would be greatly appreciated.

Regards,
Zeno



Other related posts: