[kismac] Re: Build question

  • From: m0bilitee <m0bilitee@xxxxxxxxx>
  • To: kismac@xxxxxxxxxxxxx
  • Date: Sun, 12 Feb 2006 16:23:21 -0600

Nope, I'm using compile.command in the KisMACNg folder.  I just omitted the
miles of stuff it does from my initial posting to save space.

FWIW, the compile.command does do this:

cd ../BIGL
xcodebuild -configuration Deployment
cd ../BIGeneric
xcodebuild -configuration Deployment  <--- this is where it dies for me.

Thanks!




On 2/12/06, Robin L Darroch <robin@xxxxxxxxxxxxx> wrote:
>
> That sounds suspiciously like you're trying to build it using the
> "Build" command in Xcode rather than the "compile.command" script in
> the source directory.  Try opening terminal, changing to the source
> directory and executing "./compile.command"
>
> After you've done that once, you can use Xcode for subsequent builds.
>
> At 15:45 -0600 12/2/06, m0bilitee wrote:
> >Hi, I'm new to KisMac, trying to build r83.
> >
> >First off, I had to download and install UnitKit-1.1 in order to get
> >past some undefined errors that prevented build from working.
> >
> >Besides that, though I cannot seem to get it to build.  It dies
> >during the BIGeneric portion:
> >
> >Missing dependency target "BIGL (from BIGL.xcode) (from BIGL.xcode)"
> >CompileC
>
> >build/BIGeneric.build/Deployment/BIGeneric.build/Objects-normal/ppc/BIZoomView.o
> >"/Users/m0bilitee/KisMac Source
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.m" normal ppc
> >objective-c com.apple.compilers.gcc.4_0
> >     cd "/Users/m0bilitee/KisMac Source
> r83/KisMACng/Subprojects/BIGeneric"
> >     /usr/bin/gcc-4.0 -x objective-c -arch ppc -pipe -Wno-trigraphs
> >-fpascal-strings -fasm-blocks -Os -fmessage-length=0 -mtune=G4
> >-mmacosx-version-min= 10.3 -I/Users/m0bilitee/KisMac\ Source\
>
> >r83/KisMACng/Subprojects/BIGeneric/build/BIGeneric.build/Deployment/BIGeneric.build/BIGeneric.hmap
> >-Wmost -Wno-four-char-constants -Wno-unknown-pragmas
> >-F/Users/m0bilitee/KisMac\ Source\
> >r83/KisMACng/Subprojects/BIGeneric/build/Deployment
> >-F/Users/m0bilitee/KisMac -FSource
> >-Fr83/KisMACng/Subprojects/BIGeneric/../files
> >-I/Users/m0bilitee/KisMac\ Source\
> >r83/KisMACng/Subprojects/BIGeneric/build/Deployment/include
> >-I/Users/m0bilitee/KisMac\ Source\
>
> >r83/KisMACng/Subprojects/BIGeneric/build/BIGeneric.build/Deployment/BIGeneric.build/DerivedSources
> >-mcpu=G3 -force_cpusubtype_ALL -include
>
> >/Library/Caches/com.apple.Xcode.0/SharedPrecompiledHeaders/BIGeneric_Prefix-bqnithzepqlobubajkckzxfutyvq/BIGeneric_Prefix.pch
> >-c /Users/m0bilitee/KisMac\ Source\
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.m -o
> >/Users/m0bilitee/KisMac\ Source\
>
> >r83/KisMACng/Subprojects/BIGeneric/build/BIGeneric.build/Deployment/BIGeneric.build/Objects-normal/ppc/BIZoomView.o
> >In file included from /Users/m0bilitee/KisMac Source
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.m:9:
> >/Users/m0bilitee/KisMac Source
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.h:10:22: error:
> >BIGL/BIGL.h: No such file or directory
> >In file included from /Users/m0bilitee/KisMac Source
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.m:9:
> >/Users/m0bilitee/KisMac Source
> >r83/KisMACng/Subprojects/BIGeneric/BIZoomView.h:12: error: cannot
> >find interface declaration for 'BIGLView', superclass of 'BIZoomView'
> >
> >
> >It had just built BIGL in the previous step---any idea how I can fix this
> up?
> >
> >Thanks!  (FYI, I'm on a G5 iMac with Xcode 2.2, no additional
> >optimizations other than running compile.command).
> >
> >m0b
>
>
> --
>
> -------------------------------------------------------------------------
>   Robin L. Darroch - PO Box 2715, South Hedland WA 6722 - +61 421 503 966
>        robin@xxxxxxxxxxxxx - robin@xxxxxxxxxxx - robin@xxxxxxxxxxxxx
>
>
>


--
Digital things worthwhile:  http://www.digg.com, http://del.icio.us,
http://www.boingboing.net, iTunes, Skype, Bluetooth Headset
Enjoy the documented stupidity at http://beatdown.blogspot.com

Other related posts: