[iyonix-support] Re: USB card

In message <gemini.m1jp25009untr02zc.alan@xxxxxxxxxxxxxxx>
          Alan Wrigley <alan@xxxxxxxxxxxxxxx> wrote:

> Doug Webb <doug.j.webb@xxxxxxxxxxxxxx> wrote:

>> In message <gemini.m1jg53002yxbn02zc.alan@xxxxxxxxxxxxxxx>
>>           Alan Wrigley <alan@xxxxxxxxxxxxxxx> wrote:
>> 
>>> both the keyboard and mouse refused to work. I reseated the USB card
>>> again but still no joy. ISTR that even when the machine was working the
>>> USB ports were always a bit temperamental.

>> What version of RISC OS do you have in the Iyonix and also what
>> version of !Boot.

> Erm... the one that fixed the clock problem. Was that 5.16 or 5.17?

That was 5.16.

>> The ROOL !Boot sequence will set up the correct USB drivers as they
>> are not present in anything earlier than 5.18 as far as I know.

I do not think that is correct. You are probably confusing this with 
the mass storage drivers (SoftSCSI). These are softloaded during the 
boot sequence. The basic USB drivers for keyboard and mouse are in 
ROM.

> Ah, that might explain it then. I will have to put the disc back into the
> RPC and enable the boot setting before sticking it back in the Iyo. I'll
> report back if that doesn't do the trick.

Your best bet is to attach the mouse and keyboard to the two rear USB 
sockets without a hub. If that does not work, swap them and try again.

Martin
-- 
---------------------------------------------------------------------
Martin Wuerthner           MW Software          lists@xxxxxxxxxxxxxxx
---------------------------------------------------------------------
---
To alter your preferences or leave the group, 
visit http://www.freelists.org/list/iyonix-support
Other info via http://www.freelists.org/webpage/iyonix-support
List-related queries to iyonix-support-moderators@xxxxxxxxxxxxx

Other related posts: