[hllug] Intel Video driver & firefox bug

Apparently there several known bugs on x86 with Linux 2.6.32+ kernel and the intel video driver i915. I am aware the the problems persist in at least Ubuntu 10.4 and 10.10. Issue is suppose to be fixed in newer Linux kernel source.


1. My son's laptop has an intel chipset and with Ubuntu 10.4 & 10.10 the video goes black during the Linux boot process and the machine locks up.

2. The other interesting one is triggered by Firefox. I have seen this bug on multiple Dell Dim 2400 systems with the intel 82845G video chipset. The video goes out in the wees with blinking black & white stripes and the machine locks up solid. This one is random, but is always trigger when using Firefox. Installing and using Chromium appears to prevent the lockup. One time with Chromium, I saw the black & white video image in the browser, but it did not kill X nor lockup the machine up. In fact it did not even kill Chromium!

I have seen two possible solutions to work around these problems:
=========================================
a. Add the kernel option "nomodeset" in Grub. This is suppose to fix #1, the boot-up problem. You have to get into the GRUB2 files to fix this as there is no "/boot/grub/menu.lst" anymore!

b. Add the "modeset" option to a custom "/etc/modprobe.d/i915.conf" file. This may fix problem #2 but have not tried it. I have not found any detail yet concerning format of entry in user created "i915.conf".

-Lee



______________________________________________________________________________
Highland Lakes Linux User Group (HLLUG): http://www.hllug.org
HLLUG mailing list: http://www.freelists.org/list/hllug

Other related posts: