[hipl-commit] [trunk] Rev 4725: hipd: change a variable type from size_t to int.

  • From: Mircea Gherzan <mircea.gherzan@xxxxxxxxxxxxxx>
  • To: hipl-commit@xxxxxxxxxxxxx
  • Date: Wed, 9 Jun 2010 01:55:57 +0300

Committer: Mircea Gherzan <mircea.gherzan@xxxxxxxxxxxxxx>
Date: 09/06/2010 at 01:55:57
Revision: 4725
Revision-id: mircea.gherzan@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Branch nick: trunk

Log:
  hipd: change a variable type from size_t to int.
  The size_t is an unsigned one, and using it for a variable that
  * takes the (possibly negative) retval of a call AND
  * is compared to zero
  makes no sense.

Modified:
  M  hipd/dh.c

=== modified file 'hipd/dh.c'
--- hipd/dh.c   2010-05-22 12:37:40 +0000
+++ hipd/dh.c   2010-06-08 22:53:10 +0000
@@ -24,7 +24,7 @@
  */
 int hip_insert_dh(uint8_t *buffer, int bufsize, int group_id)
 {
-    size_t res;
+    int res;
     DH *tmp;
 
     /*

Other related posts:

  • » [hipl-commit] [trunk] Rev 4725: hipd: change a variable type from size_t to int. - Mircea Gherzan