[hipl-commit] [trunk] Rev 4450: On a request from Samu, I added Ubuntu and Fedora based instructions to

  • From: Miika Komu <miika@xxxxxx>
  • To: hipl-commit@xxxxxxxxxxxxx
  • Date: Sun, 2 May 2010 15:14:45 +0300

Committer: Miika Komu <miika@xxxxxx>
Date: 02/05/2010 at 15:14:45
Revision: 4450
Revision-id: miika@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Branch nick: trunk

Log:
  On a request from Samu, I added Ubuntu and Fedora based instructions to 
  solve compilation dependencies in the INSTALL file.

Modified:
  M  INSTALL

=== modified file 'INSTALL'
--- INSTALL     2010-05-02 11:42:04 +0000
+++ INSTALL     2010-05-02 12:14:43 +0000
@@ -16,12 +16,6 @@
 HIPL dependencies
 =================
 
-In order to compile HIPL you need autotools (autoconf, automake, libtool), GNU
-Make and gcc. libgtk2.0, openssl, libxml2, iptables, libcap, libsqlite3 and
-libconfig are required complete with development headers. For Perl, Socket6,
-IO::Socket::INET6, Net::IP and Net::DNS modules are required. You can 
optionally
-install xmlto to build the HOWTO and doxygen to build the code documentation.
-
 HIPL places certain requirements on your kernel. Starting from Linux kernel
 version 2.6.27, no changes are necessary. If you run an older version, look
 at the patches/kernel directory to find patches for your Linux kernel version.
@@ -29,6 +23,30 @@
 to use the optional native programming interface, you need to patch your kernel
 anyway.
 
+In order to compile HIPL you need autotools (autoconf, automake,
+libtool), GNU Make and gcc. libgtk2.0, openssl, libxml2, iptables,
+libcap, libsqlite3 and libconfig are required complete with
+development headers. For Perl, Socket6, IO::Socket::INET6, Net::IP and
+Net::DNS modules are required. You can optionally install xmlto to
+build the HOWTO and doxygen to build the code documentation.
+
+On Ubuntu, the following command(s) should solve the dependencies:
+
+  aptitude install automake autoconf libtool gcc libgtk2.0-dev libssl-dev \
+    libxml2-dev iptables-dev libcap-dev libsqlite3-dev \
+    aptitudelibnet-ip-perl libnet-dns-perl libsocket6-perl \
+    libio-socket-inet6-perl
+
+  Optionally: aptitude install pax miredo bzr xmlto doxygen
+
+On Fedora, the following command(s) should solve the dependencies:
+
+  yum install gcc openssl-devel libxml2-devel autoconf automake libtool \
+              gtk2-devel iptables-devel libcap-devel sqlite-devel \
+              rpm-build perl-Net-IP perl-Net-DNS perl-Socket6 \
+              perl-IO-Socket-INET6"
+
+  Optionally: yum install miredo bzr xmlto doxygen
 
 How to build HIPL
 =================

Other related posts:

  • » [hipl-commit] [trunk] Rev 4450: On a request from Samu, I added Ubuntu and Fedora based instructions to - Miika Komu