[hipl-commit] [trunk] Rev 4447: Use the kernel constant for capability version.

  • From: Mircea Gherzan <mircea.gherzan@xxxxxxxxxxxxxx>
  • To: hipl-commit@xxxxxxxxxxxxx
  • Date: Sun, 2 May 2010 01:39:34 +0300

Committer: Mircea Gherzan <mircea.gherzan@xxxxxxxxxxxxxx>
Date: 02/05/2010 at 01:39:34
Revision: 4447
Revision-id: mircea.gherzan@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Branch nick: trunk

Log:
  Use the kernel constant for capability version.

Modified:
  M  lib/core/hip_capability.c

=== modified file 'lib/core/hip_capability.c'
--- lib/core/hip_capability.c   2010-05-01 22:12:45 +0000
+++ lib/core/hip_capability.c   2010-05-01 22:29:58 +0000
@@ -108,14 +108,11 @@
     uid_t uid = -1;
 
 #ifdef CONFIG_HIP_ALTSEP
-
-#define LINUX_CAPABILITY_VERSION_HIPL  0x19980330
-
     struct __user_cap_header_struct header;
     struct __user_cap_data_struct data;
 
     header.pid     = 0;
-    header.version = LINUX_CAPABILITY_VERSION_HIPL;
+    header.version = _LINUX_CAPABILITY_VERSION_1;
     data.effective = data.permitted = data.inheritable = 0;
 
     HIP_IFEL(prctl(PR_SET_KEEPCAPS, 1), -1, "prctl err\n");

Other related posts:

  • » [hipl-commit] [trunk] Rev 4447: Use the kernel constant for capability version. - Mircea Gherzan