[haiku] Re: r1a2 on an eeepc 900

Hi,

> >> > Hi, i just downloaded an irc client to test on the gcc4 image 
> >> > (liveusb),
> >> and
> >> > i am getting numerous lib* missing errors, can someone point me in the
> >> right
> >> > direction of what packages i need to get, please.
> >>
> >> Common, don't you agree this is way too unspecific to post any meaningful
> >> reply? Neither did you mention which IRC client you downloaded, nor which
> >> libs are missing. How is someone supposed to know how to help you from
> >> that?!
> >>
> >> Best regards,
> >> -Stephan
> >>
> >> Sorry Stephan,you are absolutely right. I will go into haiku, and note
> > them down,
> 
> 
> the irc client i found was bowser, and its asking for libnet.so libnetapi.so
> libstdc++.r4.so , and i also tried caya and that is asking for libexpat.so.1

In a regular Alpha image, Vision would be a pre-installed IRC client, and 
IIRC it's based in part on Bowser, at least it's a more advanced client which 
you should prefer. The missing libs seem to be caused by the fact that you 
are trying to run GCC2 software on a GCC4 only Haiku build. The problem with 
Caya could be caused by the fact that it does not include all it's libraries, 
since it probably targets a full Alpha build of Haiku, wich would normally 
include libexpat.

IIRC, someone mentioned he wanted an image as small as possible, but it may 
have been better to build a true @alpha-* profile image, configured as hybrid 
build. In another words an image which is the same as a regular Haiku Alpha2 
image, with the only difference being the IDE stack is used instead of the 
ATA stack.

Best regards,
-Stephan


Other related posts: