[haiku-webkit-commits] Re: r437 - webkit/trunk/WebKit/haiku/WebCoreSupport

  • From: "Michael Lotz" <mmlr@xxxxxxxx>
  • To: haiku-webkit-commits@xxxxxxxxxxxxx
  • Date: Tue, 20 Apr 2010 16:06:16 +0200

> Author: stippi
> Date: Tue Apr 20 13:12:20 2010
> New Revision: 437
> URL: http://mmlr.dyndns.org/changeset/437
> 
> Log:
> ...
> * Updated version in UserAgent string.
> ...
>  String FrameLoaderClientHaiku::userAgent(const KURL&)
>  {
> -     // TODO: Get the app name from the app. Hardcoded WebPositive for 
> now. Mentioning "Safari" is needed for some sites like gmail.com.
> -    return String("Mozilla/5.0 (compatible; U; InfiNet 0.1; Haiku) 
> AppleWebKit/527+ (KHTML, like Gecko) WebPositive/527+ Safari/527+");
> +     // FIXME: Get the app name from the app. Hardcoded WebPositive 
> for now. Mentioning "Safari" is needed for some sites like gmail.com.
> +    return String("Mozilla/5.0 (compatible; U; InfiNet 0.1; Haiku) 
> AppleWebKit/528+ (KHTML, like Gecko) WebPositive/528+ Safari/528+");
>  }

Shouldn't the "InfiNet 0.1" finally be replaced by WebPositive? I think 
that's where the app name is supposed to be really.

Regards
Michael

Other related posts: