[haiku-development] Re: "media-plugin" naming convention (wasRe: Donating codes: APE reader)

> The latter - while it's not strictly necessary to have encoder/decoder
> in the same file, you will often either use the same library or even
> have the reader/decoder in a single file when the container isn't
> separated from the codec (for example musepack), so I think it's
> practical to allow them to be in a single file.

Okay, that's what I was fearing too.

I guess nobody want to fake-split via symlink (readers/musepack -> 
writers/musepack...) either, so it means we can't structure media add-ons 
subfolders anymore per *purpose*.

Well. "plugins" is fine enough, let's keep it! ;-)


Other related posts: