Fredrik Modèen<fredrik@xxxxxxxxx> wrote: > Fitting name? > > ipro1000_em, ipro1000_lme ipro1000_igb. Something like that? With this wee > keep the name from FreeBSD even better would be to rename ipro1000 to > e1000 ;) but I think the ipro1000 says more than e1000 That's why I specificially mentioned it: I don't consider those good names. Haiku driver names should be descriptive for the hardware they are serving -- not for the FreeBSD driver they are based on. > Will test that. special if_em.c and if_lem.c looks the same and have the > same function etc. but when I read about them in FreeBSD they talk about > not being the same. Can be that there are more files not needed in one and > not the other.. > > So to not change the FreeBSD driver that much I still one the path to > create 3 separate drivers from the same source. That will definitely be the easier way to go, even though I think it's not a good one if the drivers are sharing that much code -- but I guess we just have to suffer from this FreeBSD decision. Anyway, please disregard my Jamfile suggestions, and use what Ingo mentioned; ie. build a kernel static library out of the common sources. Bye, Axel.