[haiku-development] Re: USB MIDI update

On Wed, Sep 9, 2009 at 4:00 PM,  <pete.goodeve@xxxxxxxxxxxx> wrote:
>
> I tried... (:-/)  I think it does mostly, except that identifiers in the
> original (Haiku) version (and its BeOS ancestors, I guess) use underlines
> rather than camelCase, so I followed that convention in stuff I added.
> (As it's C, rather than C++, a lot of the guidelines don't really apply
> anyway.)

Just some quick suggestions:

Things you should definitely change:

- The copyright header style you used is still not in line with our
coding guidelines. Remove all the extra * characters.
- There are also extra spaces in some array indexing (like_this [i])
and that is just plain hard to read, so please fix that.

Things that would be good (maybe in a separate style fixing patch):

- You could fix the header order in the files you touched to match the
guidelines.
- You could fix the function style too (return type on its own line,
two lines between functions.)
- You could remove the space between a function and its first
parenthesis (on both function definitions and calls.)

I know a lot of the above existed before, but we generally want to try
to fix style when working on something. Hopefully over time all the
code will be updated. On the new code you added the style seems pretty
good, with the exception of a few extra spaces in some if statements
and casts.

Oh and thanks for this work, I have a USB MIDI keyboard too and it
will be very nice to be able to use it in Haiku, once all the kinks
are worked out. In fact I could help test this if you want (maybe once
the alpha is out.)

-- 
Regards,
Ryan

Other related posts: