[haiku-development] Re: USB MIDI?

On Tue, Jun 30, 2009 at 10:20:51PM -0700, pete.goodeve@xxxxxxxxxxxx wrote:
> On Tue, Jun 30, 2009 at 06:07:52PM -0700, pete.goodeve@xxxxxxxxxxxx wrote:
> > On Tue, Jun 30, 2009 at 04:56:40PM -0700, scott mc wrote:
> > > On Mon, Jun 29, 2009 at 7:29 PM, <pete.goodeve@xxxxxxxxxxxx> wrote:
> > > 
> > > http://dev.haiku-os.org/changeset/31342
> > > So just grab a build on or after r31342 and the usb midi should be 
> > > enabled.
> > > Let us know how it works for you.
> > 
> I'm afraid it doesn't work any better. (:-(  Get exactly the same error.
> 
> Filed as Ticket #4053.

Siarzhuk Zharski suggested that I simply disable the 'set_alternate_interface'
that it seems to be stalling on, but doing that simply moves the error
a bit further on.

I'll keep working on debugging this, as it's kind of essential to me.
[Except that the module seems to have no MIDI *output* facility! (unless
I'm completely misreading what's needed -- 'usb_midi_write' simply returns
B_ERROR.)  So I may have quite a bit of work to do!]  Unfortunately I know
almost zero about USB at the moment, so research will have to be done.

I'm wondering if the problem is actually in the uhci driver, as I gather
this is a bit less mature that the others.  Has anybody used usb_midi
successfully with, say, ohci?  I seem to have no problems with other
USB devices, like flash drives, so I don't know...

Any thoughts appreciated.

(In passing, this ThinkPad has an "UltraBase", which includes a gameport,
and the 'emuski' driver seems to be loaded, but again no midi port of
any kind is visible.  I'd think there should be, but again, does anybody
know of a reason for its absence?)

Cheers,
                -- Pete --


Other related posts: