[haiku-development] Re: Ruby to drop support for 9 platforms, including BeOS

On Tue, Jul 29, 2008 at 9:37 AM, François Revol <revol@xxxxxxx> wrote:
>> As announced here...
>>
>> http://www.rubyinside.com/ruby-1-9-0-3-and-drops-support-for-9-platforms-970.html
>> >
>> ...Ruby plans to drop support for 9 platforms, including BeOS. Per
>> the
>> announcement, Ruby developers plan to "remove platform-specific codes
>> for them from Ruby, unless someone become a maintainer by 25 Sep."
>>
>> I am not sure who maintained the BeOS specific code, or if there is
>> anyone interested in avoiding the BeOS code from being removed (for
>> the sake of future Haiku support, that is), but thought I would
>> notify
>> the Haiku developers in case there is anyone out there who would like
>> to step up.
>
> Olivier ?
>
> I think he told me he played with ruby on BeOS...
>
>
> François.
>
>

I just ran a quick build attempt on Ruby 1.8.7-p22.  Initial
./configure shows a few missing headers and then bombs out, I've added
this to the portlog on HaikuPorts:
http://ports.haiku-files.org/wiki/dev-lang/ruby/1.8.7-p22

-scottmc

Other related posts: